API Outage
Incident Report for Altmetric
Resolved
All dataset reloads have completed succesfully and we have now verified that the API and dependent services are fully operational and in a stable state.
Posted Jul 13, 2020 - 12:31 UTC
Monitoring
Dataset reload has been completed on 2/3 instances and we are currently monitoring the third for completion. API functionality is currently restored for all services but we will continue monitoring for the next hour to ensure service is fully stable.
Posted Jul 13, 2020 - 11:16 UTC
Identified
The issues have been traced back to a database primary instance restarting and causing a full re-sync and dataset reload across all secondary instances, thus blocking requests while the dataset is loaded into memory. We are currently working to resolve the situation and restore API service and will update shortly.
Posted Jul 13, 2020 - 11:01 UTC
Investigating
We are currently experiencing issues with the main Altmetric API (this includes basic, badges and Detail pages functionality) and are currently investigating the cause.
Posted Jul 13, 2020 - 10:53 UTC
This incident affected: Altmetric API (Commercial API, Free API), Altmetric Badges (Badge API), and Altmetric Details Pages.